MasterFile DocumentationGetting Started ArticlesCopying profiles between databases

Copying profiles between databases

You can copy a profile from one database to another. This is most useful when copying keywords such as document types or issues that you have created and now need again, rather than having to recreate them, or to add into a Case Template you're customizing for future matters of that type (see Creating practice specific case templates).

Notes:

  • When you copy a profile from one case to another, both MasterFile cases must be the same version and build. Allthough this is usually the case, you can check the version of both source and destination databases from Help > About this Application in each. The version and build is listed under the splash screen.
  • To copy and paste a document and its extracts, you need to select them all. Then, after pasting into the target database, select those profiles in the target and run the Extract Refresher for selected documents from [R+] > Profile Maintenance > Extract Refresher. You might find the [L+] > Miscellaneous > by Entered Date useful for that as the just pasted profiles will be at the top.
  • Any doc-links (the yellow link icons) will still exits but not work as being are specific to the source database, they will in fact still be pointing to profiles in the source database, so you must delete them from any player, fact or document profiles, etc. in the target database. In actuality, the doclinks are only relevant to and created within the context of the source database's and would not make sense anywhere else.

Here, I've selected the three keyword profiles I want to copy and I can use Edit > Copy or press Ctrl+c to copy them

Clicking on the destination database's tab to make it active, I then switch to the appropriate view (documents, facts, or in this case keywords), and then ...

choose Edit > Paste or press Ctrl+v to paste the profiles to the destination database.

  • Be careful copying Keywords. If you just select them all and copy into the destination database, you'll end up with duplicates.
  • Generally you will only select your own keywords to copy, not MasterFile system or default keywords.